Magento2 imposta la modalità di manutenzione


10

Sto abilitando la modalità di manutenzione aggiungendo un file var/.maintenance.flag, ma sto ottenendo l'errore:

Unable to proceed: the maintenance mode is enabled. 
#0 /backup/html/magento2/vendor/magento/framework/App/Bootstrap.php(256): Magento\Framework\App\Bootstrap->assertMaintenance()
#1 /backup/html/magento2/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#2 {main}

Ho anche provato ad abilitarlo usando il comando:

bin/magento maintenance:enable

Inoltre, abilitata la modalità di produzione, svuotato le cache non ricevo ancora la pagina 503. Per favore aiuto!

Risposte:


12

La modalità di manutenzione indica che il sito Web è offline.
Quindi funziona come previsto.
Se si desidera rimuovere la modalità di manutenzione in esecuzionebin/magento maintenance:disable


2
Non dovrebbe essere visualizzato: "Il server non è temporaneamente in grado di soddisfare la tua richiesta a causa di tempi di inattività della manutenzione o problemi di capacità. Riprova più tardi." cioè 503.phtml?
— Twinkal,

Probabilmente hai ragione. Ma non sono sicuro
— Marius

4
Questo non risponde alla domanda dell'eccezione.
— Robert Egginton,

11

Ero MAGE_MODEimpostato come sviluppatore e avevo distribuito in produzione usando:

php bin/magento deploy:mode:set production

supponendo che sia un modo dinamico di cambiare la modalità sviluppatore in produzione.

Ho dovuto cambiare il MAGE_MODEper productiono defaultper ottenere la pagina 503.

Mi piacerebbe sapere la differenza tra MAGE_MODEe modalità di distribuzione.


1
Penso che i valori impostati sulla configurazione del server (come MAGE_MODE) abbiano la precedenza sui valori di config.phpe env.php. Ecco perché la tua modalità sviluppatore era attiva anche se l'hai impostata diversamente tramite cli.
— Marius

Hai ragione !! .. Non trovo nulla, config.phpma in env.phpesso cambia il MAGE_MODEvalore in base al comando cli. Grazie :)
— Twinkal,

1

Puoi provare questo. Esegui il seguente comando (poiché non l'ho ancora provato, crea un backup di Magento)

1) / bin / magento maintenanca: disabilita

Se non risolto utilizzando il primo comando e viene visualizzato un errore del tipo " Il server non è temporaneamente in grado di soddisfare la richiesta a causa di tempi di inattività della manutenzione o problemi di capacità. Riprovare più tardi ". In tal caso, controllare qui .

2) Ora esegui il comando :: / bin / magento manutenzione: stato
3) / bin / magento manutenzione: abilita


0

Quando sei in Magento developer mode-> quindi attiva maintenance mode-> otterrai il messaggio di errore che hai descritto

Quando sei in qualsiasi altra modalità -> quindi attiva maintenance mode-> otterrai la pagina 503


1
Sembra, non importa quale modalità usi, mostra sempre un'eccezione.
— Kirby,
Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.