Usare un VRF è come usare un router separato. Se si dispone dello stesso IP WAN per entrambi i VRF, è necessario configurarlo due volte in entrambe le interfacce WAN. Se tuttavia usi solo un'interfaccia WAN, dovrai dividere questa interfaccia trunking (usando le VLAN) o sottointerfacce.
ex:
interface FastEthernet0.5
encapsulation dot1Q 5
ip address 1.1.1.1 255.255.255.252
Si noti che non utilizziamo l'inoltro di IP VRF, qui stiamo usando il VRF predefinito
interface FastEthernet0.10
ip vrf forwarding wanconnection:1
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.252 (<== this can be another IP if you prefer to divide it with 2 different IP's)
La connessione quindi procede come segue:
- router (vrf normale) => wan connection => vpn utilizzato per il tag dot1Q 5
- il tuo router (wanconnection: 1 vrf) => wan connection => vpn usato per il tag dot1Q 10
se vuoi farlo senza taggare e hai solo 2 interfacce fisiche, è la stessa implementazione:
interface FastEthernet0
ip address 1.1.1.1 255.255.255.252
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 1.1.1.1 255.255.255.252
Ogni altra interfaccia necessaria nello specifico vrf "wanconnection: 1" deve essere aggiunta allo stesso modo:
ip vrf forwarding wanconnection:1
ex:
interface FastEthernet4
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
fare un vrf: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/vrf.html
ip vrf wanconnection:1
rd 65000:1
Spiegazione del comando rd 100: 1: crea una tabella VRF specificando un identificatore di rotta. Immettere un numero AS e un numero arbitrario (xxx: y) o un indirizzo IP e un numero arbitrario (ABCD: y).
per la parte di routing:
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 1.1.1.2
Se si dispone di una sola connessione WAN senza tag abilitato, è possibile utilizzare il routing inter Vrf: http://packetlife.net/blog/2010/mar/29/inter-vrf-routing-vrf-lite/
ex:
ip vrf wanconnection:1
rd 65000:1
route-target export 65000:2
route-target import 65000:99
ip vrf wanconnection:2
rd 65000:2
route-target export 65000:1
route-target import 65000:99
ip vrf shared:1
rd 65000:99
route-target export 65000:99
route-target import 65000:1
route-target import 65000:2
interface FastEthernet0
ip vrf forwarding shared:1
ip address 1.1.1.1 255.255.255.252
interface loopback1
ip vrf forwarding shared:1
ip address 2.2.2.2 255.255.255.255
ip route vrf shared:1 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 2.2.2.2
ip route vrf wanconnection:2 0.0.0.0 0.0.0.0 2.2.2.2
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
description "LAN interface vrf 1"
interface FastEthernet2
ip vrf forwarding wanconnection:2
ip address 10.0.2.1 255.255.255.0
description "LAN interface vrf 2"
qui FastEthernet1 utilizzerà la route predefinita per vrf wanconnection: 1 e FastEthernet2 utilizzerà la route predefinita per vrf wanconnection: 2 (fornita dai comandi "ip route").