Errore durante l'avvio di Tomcat da NetBeans - '127.0.0.1 *' non è riconosciuto come comando interno o esterno


148

Sia Google che Stackoverflow mi hanno mostrato persone con problemi simili, tuttavia questo errore è leggermente diverso in quanto l'indirizzo IP è suffisso da un asterisco:

NetBeans 8.0.1 mi dà il seguente errore quando provo ad avviare Tomcat.

'127.0.0.1 *' non è riconosciuto come comando interno o esterno, programma eseguibile o file batch.

Ho installato sia Tomcat 7.0.56 che Tomcat 8.0.14, entrambi iniziano OK dalla riga di comando (uno alla volta). Li ho aggiunti all'elenco dei server di NetBeans come Tomcat 7 e Tomcat 8.

Ho un'app Web "Hello World" che ho configurato:
Proprietà -> Esegui -> Server: ho provato sia Tomcat 7 che Tomcat 8
Entrambi danno lo stesso errore.

Se provo ad avviare Tomcat utilizzando:
Servizi -> Server -> Tomcat 7 -> Avvia
servizi -> Server -> Tomcat 8 -> Avvio
Ottengo lo stesso errore di quando provo ad avviare un'app Web:

'127.0.0.1 *' non è riconosciuto come comando interno o esterno, programma eseguibile o file batch.

Qualche idea ?
Anche se è solo quello che ci fa quell'asterisco?


Possibile duplicato di Avvio di Tomcat fallito da Netbeans
— YoYo

Se si desidera leggere un'analisi più approfondita su questo bug, vedere la mia risposta StackOverflow dal 2015 qui stackoverflow.com/questions/30647156/...~~V~~singular~~3rd È per TomEE ma basata su Tomcat in modo che la stessa soluzione funziona anche qui. Anche la disattivazione delle impostazioni proxy in Netbeans funziona ovviamente, come suggerito da altri.
— Miklos Krivan,

Risposte:


378

Supponendo che tu sia su Windows (questo errore è causato dalla fuga di file bat scadenti), è un errore introdotto nelle ultime versioni ( 7.0.56e 8.0.14) per risolvere un altro errore. Prova a rimuovere il "intorno alla JAVA_OPTSdichiarazione in catalina.bat. L'ho risolto per me con Tomcat 7.0.56ieri.

In 7.0.56in bin/catalina.bat:179e184

:noJuliConfig
set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%"

..

:noJuliManager
set "JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%"

per

:noJuliConfig
set JAVA_OPTS=%JAVA_OPTS% %LOGGING_CONFIG%

.. 

:noJuliManager
set JAVA_OPTS=%JAVA_OPTS% %LOGGING_MANAGER%

Per il tuo asterisco, potrebbe essere solo una tua configurazione da qualche parte che lo aggiunge alla dichiarazione dell'host.

L'ho visto ieri sul bugtracker di Tomcat ma non riesco a trovare di nuovo il link. Modifica Trovato! https://issues.apache.org/bugzilla/show_bug.cgi?id=56895

Spero che risolva il tuo problema.


1
Ha funzionato per Tomcat 8.0.18 / Netbeans 8.0.2 - Grazie!
— Predrag Stojadinović,

Ha funzionato per me. Sto usando Tomcat 7.0.59, grazie!
— Sivakumar,

Ha funzionato per me, ma su diverse linee: 196 e 201. NetBeans 8.0.2 e Tomcat 8.0.21. Grazie.
— zmirc,

Sì, questa soluzione è corretta. Ma la mia domanda è `perché l'unico problema in Netbeans? Quando uso lo stesso server nel progetto eclipse funziona ma in netbeans non funziona '
— Yubaraj

@Yubaraj è probabilmente perché Netbeans chiama lo script catalina.bat come parametro di un altro comando usando le virgolette, qualcosa del genere othercommand --run "catalina.bat"che causerebbe un ulteriore problema di fuga nello script. Come affermato nella mia risposta, la fuga di file bat è orribile. Questa è solo la mia ipotesi però.
— Johnride,

52

Dopo aver seguito i passaggi di @Johnride, ho ancora ricevuto lo stesso errore.

Ciò ha risolto il problema:

Strumenti-> Opzioni-> Seleziona nessun proxy

fonte: https://www.youtube.com/watch?v=uI1j-8F8eN4


Avevo bisogno di usare entrambe le soluzioni per risolverlo nella mia macchina.
— HadesDX,

3
Questo in realtà lo risolve per me per Tomcat 8.0.36, non rimuovendo le virgolette su JAVA_OPTS.
— John Mikic,

2
Strumenti -> Opzioni -> Generale -> Impostazioni proxy: Nessun proxy
— gps

Impossibile trovare: noJuliConfig impostato "JAVA_OPTS =% JAVA_OPTS%% LOGGING_CONFIG%": noJuliManager impostato "JAVA_OPTS =% JAVA_OPTS%% LOGGING_MANAGER%" nel file catalina.bat ma la tua soluzione Strumenti -> Opzioni -> Generale -> Impostazioni proxy: Nessun proxy ha funzionato per me in Netbeans 8.0 e Tomcat 8.5.13
— Joseph

8

Strumenti-> Opzioni-> Seleziona nessun proxy funzionato per me


Questa risposta è solo una copia diretta della soluzione di Sumama Waheed. Dovresti eliminare questo.
— skomisa,

0

Non ho provato la risposta di Sumama Waheed, ma quello che ha funzionato per me è stato sostituire il bin / catalina.jar con un vaso funzionante (ho eliminato un vecchio gatto selvatico) e dopo aver aggiunto NetBeans, ho inserito nuovamente l'originale catalina.jar.

Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.