Errore: "Impossibile leggere la sezione di configurazione" system.webServer / management / delegation "perché manca lo schema


91

Sto cercando di pubblicare un sito Web dal mio computer su un server Web IIS tramite distribuzione Web.

Ho 3 server. Tutti i server hanno installato le stesse cose (Webdeploy ecc.) E vengono avviati i servizi (Web Deployment Agent Service e Web Management Service).

Sul primo server non ho problemi di connessione. Ma gli altri due server mi danno qualche errore quando "Convalida la connessione" in Visual Studio a IIS. Quando guardo i log sul server IIS, ci sono i miei elenchi di accessi con codice html 200 (ok).

Si è verificato un errore durante l'elaborazione della richiesta sul computer remoto. Nome file: MACHINE / WEBROOT

Errore: la sezione di configurazione "system.webServer / management / delegation" non può essere letta perché manca lo schema

Non ho davvero idea di cosa potrebbe risolvere questo problema e spero che tu sia in grado di aiutarmi.


Si noti che poiché la distribuzione Web viene spesso utilizzata da Visual Studio tramite il comando Pubblica, questa domanda non è effettivamente off-topic e il limite di 5 tag mi impedisce di aggiungere Visual Studio
— Carl Onager

Risposte:


66

Disinstallare e quindi reinstallare Web Deploy.

Questo ha risolto il problema per me - l'opzione 'riparazione' nell'installer non lo faceva.


118

Ho avuto lo stesso identico problema, si è scoperto che avevo installato Web Deploy 3.6 su 3.5. Rimuovere Web Deploy 3.6 e reinstallare 3.5 e vedere se risolve il problema.

Puoi anche provare @ james-wilkins commentando di seguito: "Nel mio caso ho installato Web Deploy PRIMA di installare il servizio di gestione ..."


5
Grazie mille. Ho scoperto che alcuni componenti non vengono installati correttamente quando si utilizza Web Deploy 3.6. La disinstallazione di Web Deploy 3.6 e l'installazione 3.5 mi hanno aiutato. Se vuoi essere su Web Deploy 3.6 puoi disinstallare 3.5 e reinstallare 3.6 (la disinstallazione da Web Deploy 3.5 non disinstalla i componenti mancanti, quindi Web Deploy 3.6 funziona bene quando 3.5 era installato prima).
— lucamuh

5
Disinstallare Web Deploy 3.6, quindi installare 3.5 e 3.6 ha funzionato per me dopo un'ora di mal di testa. Il sistema operativo è Win Server 2012 R2. Grazie.
— Partecipante alla riunione il

4
Ho avuto lo stesso identico problema, ho rimosso Web Deploy 3.5e reinstallatoWeb Deploy 3.6
— A-Sharabiani

74
Nel mio caso ho installato Web Deploy PRIMA di installare il servizio di gestione. Ho provato a "modificare" l'installazione per includere il servizio di gestione (oppure puoi aggiungere la funzionalità da aggiungere / rimuovere funzionalità di Windows), ma non è stato d'aiuto (ho ricevuto l'errore in questo post). Alla fine una semplice disinstallazione e reinstallazione di 3.6 è stato ciò che ha funzionato per me. Sembra che sia necessario installare PRIMA il servizio di gestione Web. Le tipiche istruzioni di MS non lo menzionano nemmeno.
— James Wilkins

11
Ho avuto esattamente lo stesso caso di @JamesWilkins.
— Jack Lu

18

Nel mio caso, ho installato Web Deploy PRIMA di installare il servizio di gestione. Ho provato a fare una "modifica" all'installazione per includere il servizio di gestione (oppure puoi aggiungere la funzionalità da aggiungere / rimuovere funzionalità di Windows), ma ciò non ha aiutato (ho ricevuto l'errore in questo post). Alla fine, una semplice disinstallazione e reinstallazione di 3.6 era ciò che ha funzionato per me. Sembra che sia necessario installare PRIMA il servizio di gestione Web. Le tipiche istruzioni di MS non lo menzionano nemmeno.


1
Esattamente il mio problema. Così strano, molte delle funzionalità di Web Deploy non sono nemmeno disponibili durante l'installazione se non hai installato prima WMSvc.
— marsze

Questo è vero. Dopo tutto, Web Deploy deve essere installato. Controllare il collegamento seguente per la risoluzione dei problemi docs.microsoft.com/en-us/iis/publish/troubleshooting-web-deploy/…
— JohnnyJaxs
Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.