Cosa causa un errore 400 Bad Request per null (“”) e perché i nostri registri nginx dovrebbero avere così tanti?


9

I registri giornalieri di Logwatch riportano regolarmente 400 richieste non valide, null: 1744 Tempo (i) dai nostri registri nginx.

Le voci del registro sono simili a:

123.123.123.123 - - [25/Jan/2011:14:44:19 -0500] "-" 400 173 "-" "-"

Qualcuno può spiegare come vengono generati e perché ce ne sono così tanti? Non sembra far male a niente, ma abbiamo avuto fino a 8000 in un giorno. Ospitiamo un'applicazione di rotaie di medie dimensioni in esecuzione su unicorno e nginx.

C'è qualche discussione nel forum nginx, ma non ho trovato una soluzione reale che riduca il numero per 400 Bad Reqeusts registrati.


1
Quali sono gli indirizzi IP che fanno le richieste sbagliate? Come indicato nel thread, potrebbe essere un programma di monitoraggio che apre solo una connessione TCP.
— Mark Wagner,

Esistono molti indirizzi IP. La maggior parte ha una sessione che include il normale traffico Web misto a questi 400. Penso di aver visto l'attività dei browser IE solo in esempi in cui mi sono concentrato sul traffico di una sessione.
— johnml,

1
Ho notato sul mio server che l'utilizzo di Firefox per accedere a una pagina fornisce sempre uno di questi 400 registri vuoti esattamente 5 secondi dopo l'ultima richiesta valida, mentre Firebug non mostra errori. Questo dà credito alla risposta di @ Avleen.
— Phrogz,

Risposte:


8

Ciò accade spesso quando un browser utilizza Keep-Alive e raggiunge il timeout keep alive. È abbastanza normale.

Se vedi 400 errori con un URI / percorso / metodo come GET o POST, ecc., Allora hai un problema legittimo con un utente che fa una richiesta errata. Ma quelli dovrebbero essere rari.

Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.