Postfix: "Connessione scaduta" su tutte le email in uscita [chiuso]


24

Ho tentato di impostare mailing list con GNU Mailman ma è stato un disastro completo con tonnellate di blocchi stradali. Postfix è in grado di ricevere e-mail ma di non rispedirle affatto, ho sbirciato nel registro e questo è quello che ho trovato:

Mar 30 16:35:30 apott-server postfix/smtp[22572]: connect to gmail-smtp in.l.google.com[74.125.142.26]:25: Connection timed out
Mar 30 16:36:01 apott-server postfix/smtp[22572]: connect to alt1.gmail-smtp-in.l.google.com[173.194.76.27]:25: Connection timed out
Mar 30 16:36:31 apott-server postfix/smtp[22572]: connect to alt2.gmail-smtp-in.l.google.com[74.125.131.26]:25: Connection timed out
Mar 30 16:37:01 apott-server postfix/smtp[22572]: connect to alt3.gmail-smtp-in.l.google.com[173.194.67.27]:25: Connection timed out
Mar 30 16:37:31 apott-server postfix/smtp[22572]: connect to alt4.gmail-smtp-in.l.google.com[173.194.65.26]:25: Connection timed out
Mar 30 16:37:31 apott-server postfix/smtp[22572]: A0616100CCB: to=<example@gmail.com>, relay=none, delay=150, delays=0.06/0.01/150/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[173.194.65.26]:25: Connection timed out)

Quindi chiaramente qualcosa impedisce la posta elettronica in uscita, qualcuno ha qualche suggerimento su come risolvere questo problema?

(Il server è una scatola di Ubuntu Linux)

Grazie per qualsiasi aiuto.


3
Quale hosting stai usando? Potrebbe trattarsi semplicemente del caso in cui la tua macchina sia collegata a una rete, il che non consentirà la posta in uscita?
— Kasperd,

@kaspered È la mia macchina sulla mia rete. C'è posta in entrata e in uscita, l'ho già fatto su macchine diverse, c'è qualcosa che non va in questo specifico.
— APott

Questo potrebbe essere per un gran numero di motivi, inizia digitando il tuo IP mailserver in MXTOOLBOX qui , può succedere se il tuo server è su una banda larga di classe domestica o non hai un record PTR per il tuo IP, o sei su un lista nera.
— 0x7c0

@Shutupsquare Dice che non ci sono problemi.
— APott

Stai usando una banda larga domestica? O è un servizio a banda larga per le imprese?
— 0x7c0

Risposte:


17

Il timeout della connessione indica che i pacchetti TCP SYN non stanno recuperando i SYN-ACK. Ciò significa che qualcosa deve bloccare i SYN o i SYN-ACKS.

Puoi usare traceroute per scoprire fino a che punto arrivano i tuoi pacchetti SYN

traceroute -n -T -p 25 gmail-smtp-in.l.google.com

Si noti che esistono diversi comandi traceroute per Ubuntu. Il comando sopra funziona con traceroute.db, ma non con traceroute-nanog o inetutils-traceroute.

Può essere utile eseguire un secondo traceroute usando la porta 80 anziché la porta 25 per il confronto.


1
Grazie per la risposta. L'output è il seguente: traceroute in gmail-smtp-in.l.google.com (74.125.142.27), 30 hopsmax, pacchetti da 60 byte 1 192.168.1.254 3.567 ms 20.770 ms 20.768 ms 2 * * * 3 * * * 4 * * * 5 * * * 6 * * * 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 * * * 19 * * * 20 * * * 21 * * * 22 * ​​* * 23 * * * 24 * * * 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * *
— APott

4
Tale output mostra che i pacchetti SYN non lo stanno realizzando al di fuori della propria rete. I pacchetti SYN sono bloccati da 192.168.1.254 o dal router successivo sul percorso. È possibile confrontare l'output con un altro utilizzando la porta 80.
— Kasperd

5
Per chiunque abbia trovato questa domanda ma è su AWS EC2: la velocità SMTP in uscita è intenzionalmente limitata , ma puoi chiedere di rilassarla .
— msanford,

Il router +1 ha utilizzato una whitelist dei server SMTP per impostazione predefinita ...
— Willi Mentzel,

Sto avendo gli stessi problemi, fare il confronto con la porta 80 e i risultati del traceroute avranno tutti un senso!
— dustbuster,

3

Questo potrebbe non essere correlato, ma lo pubblicherò qui perché ho avuto difficoltà a trovare la risposta alla mia domanda. Sono stato in grado di far funzionare l'e-mail in uscita da una scatola virtuale vagabonda modificando il mio /etc/resolv.confper utilizzare il nameserver di Google anziché l'IP 10.0.xx su cui era impostato:

sudo vi /etc/resolv.conf

Cambia l'IP del nameserver:

nameserver 8.8.8.8

Quindi dovrai riavviare postfix:

sudo /etc/init.d/postfix restart

Questo era esattamente quello che stavo cercando sulla mia scatola vagabonda. Grazie!
— porcate il

2
non è la mia domanda da accettare.
— porcate il

1
Penso che questo non sia correlato poiché traceroute è stato in grado di risolvere il nome host in un indirizzo IP. Non penso che Postfix dica Connection timed outquando la risoluzione DNS non riesce, perché sarebbe fuorviante.
— Kasperd,

2

Configurare un host di inoltro sul server isp smtp, in: /etc/postfix/main.conf

quindi ricaricare: ricaricare postfix sudo service


15
L'IT sarebbe utile per spiegare quale impostazione è cioè relayhoste forse spiegare prima la causa del problema del PO: che per combattere lo spam molti ISP dei consumatori bloccano la posta in uscita e costringono gli utenti a usare i loro server SMTP.
— HBruijn,
Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.