SpinRite 6 Errore "MBR seguito da EFI"


9

Quando eseguo SpinRite 6 sul mio computer Windows con un'unità da 3 TB, viene visualizzato un MBR Followed by EFIerrore rosso accanto all'unità, con un messaggio che dice che non dovrebbe essere eseguito a meno che l'MBR non sia "riparato". Qual è la causa di questo errore e come posso risolverlo?

Risposte:


12

Ho ricevuto la seguente risposta dal supporto SpinRite:

L'attuale versione di SpinRite, v6.0, è stata completata nel 2004 prima dell'era delle partizioni GPT, quindi non è completamente a conoscenza di quello stile di formattazione del disco rigido. Di conseguenza, SpinRite v6.0 può gestire unità in formato MBR fino a 2,2 terabyte, ma non unità in formato GPT di QUALSIASI dimensione.

Le GPT (tabelle delle partizioni GUID) sono necessarie solo per unità di dimensioni superiori a 2,2 terabyte poiché le tabelle delle partizioni in formato MBR sono limitate dai rispettivi campi a 32 bit per specificare le dimensioni della partizione e la posizione iniziale. 32-bit == 4,294967,296 e se hai tanti settori da 512 byte, finisci con 2.199.023.255.552 byte ... o 2,2 terabyte.

Anche se questo non ti aiuta ora, il supporto per le partizioni in formato GPT è una delle caratteristiche principali della prossima versione (v6.1) di SpinRite - a cui tutti i proprietari esistenti della v6.0 potranno aggiornare gratuitamente .

Tuttavia, non esiste una linea temporale nella prossima versione di SpinRite.

Grazie per la collaborazione, il tempo e la pazienza.

Quindi, non sembra che l'attuale versione di SpinRite supporti unità moderne di grande capacità.


1
Grazie per aver segnalato questo. 6.1 sembra vicino oggi, come dice l'autore nel suo podcast normale, ma non ha ancora una sequenza temporale fissa.
— Marcel,
Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.