"Errore GPG: le seguenti firme non sono valide: KEYEXPIRED"


32

L'errore che sto riscontrando quando provo ad aggiornare il mio elenco di pacchetti.

W: GPG error: http://download.opensuse.org ./ Release: The following signatures were invalid: KEYEXPIRED 1436387333
E: Some index files failed to download. They have been ignored, or old ones used instead.

Risposte:


11
GPG error: http://download.opensuse.org ./ Release: The following signatures were invalid: KEYEXPIRED 1436387333

Questo dice che la tua chiave GPG per quel repository è scaduta, il che significa una delle due cose: il tuo sistema ha una data errata o la chiave è davvero scaduta. Per i successivi, è necessario contattare il manutentore del repository e importare la nuova chiave (rimuovendo probabilmente quella precedente), una volta che il repository aggiorna le proprie chiavi per firmare i file.

Puoi tranquillamente ignorare questi messaggi se non stai usando pacchetti di questi repository. Il messaggio può essere rimosso se si rimuove il repository dal proprio source.listfile / directory.


... suggerire di aggiungere confermando che l'orologio di sistema è almeno ragionevolmente corretto. Se il sistema pensa al 2020, scommetto che porterebbe a errori scaduti chiave.
— derobert,

37

Non ho le risposte sopra, il mio orologio di sistema andava bene. Per me ha funzionato:

sudo apt-key list | grep "expired: "
sudo apt-key adv --keyserver keys.gnupg.net --recv-keys [KEY]

La chiave è la parte dietro la barra: 0000X/<this part is the key>

O usa questa fodera:

sudo apt-key list  | grep "expired: " | sed -ne 's|pub .*/\([^ ]*\) .*|\1|gp' | xargs -n1 sudo apt-key adv --keyserver keys.gnupg.net --recv-keys 

1
Grazie, risolto il problema per me con MySQL ma usato --keyserver pgp.mit.edu. Fonte: bugs.mysql.com/bug.php?id=85029
— Craig van Tonder

7

Quel ppa è stato rimosso e non esiste più. È necessario trovare una fonte diversa per i pacchetti installati tramite il ppa samrog131.

Nel frattempo, esegui i seguenti comandi per risolvere la situazione.

Innanzitutto, per eliminare la chiave scaduta:

sudo apt-key del 1436387333

Quindi, per eliminare il ppa:

sudo rm /etc/apt/sources.list.d/samrog131*
sudo apt-get clean
sudo apt-get update

Se è necessario aggiungere una chiave, vedere qui .

sudo apt-get upgrade

Potresti voler eseguire:

sudo apt-get dist-upgrade

a seconda della situazione. Se non sei sicuro, vedi qui .


Questo non risolverà nulla. APT tenterebbe di recuperare nuovamente i pacchetti dal PPA, e fallire di nuovo
— Braiam

@Braiam In realtà, risolve il problema dell'errore 404 per il ppa samrog131 mancante, quello che hai eliminato dalla domanda.
— mchid

Abbiamo già duplicati che trattano questo problema , non hai risposto completamente alla domanda, poiché hai ignorato la parte più importante che era l'errore GPG. Per favore, non modificare di nuovo la domanda.
— Braiam,

@Braiam perché no, solo per far sembrare che la mia risposta non risolva nulla?
— mchid

1) Se l'utente ha aggiunto direttamente il ppa nell'elenco sources.list, la tua risposta fallirà, in realtà fallirà se non viene usato il repository add-ppa e l'OP ha semplicemente nominato il file in modo diverso. 2) Se si rimuove la chiave, ora l'avviso verrà sostituito con un errore, poiché la chiave non è stata trovata, creando quindi più problemi.
— Braiam,


2

Nessuno di questi ha funzionato per me:

$ sudo apt-key adv --keyserver hkp://pgp.mit.edu:80 --recv-keys 5072E1F5

o

$ sudo apt-key adv --keyserver pgp.mit.edu --recv-keys 5072E1F5

o

$ sudo apt-key adv --keyserver pgp.mit.edu --recv-keys A4A9406876FCBD3C456770C88C718D3B5072E1F5

Le fonti per questi sono: https://bugs.mysql.com/bug.php?id=85029 e https://bugs.mysql.com/bug.php?id=94378

Ho eseguito un'operazione sospetta in preda alla disperazione (dicendo 'y' invece di 'N' di seguito) che penso non fosse affatto richiesta:

$ sudo apt-get install mysql-apt-config

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be upgraded:
  mysql-apt-config
1 upgraded, 0 newly installed, 0 to remove and 294 not upgraded.
Need to get 35.6 kB of archives.
After this operation, 0 B of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  mysql-apt-config
Install these packages without verification? [y/N] y
Get:1 http://repo.mysql.com/apt/ubuntu/ trusty/mysql-apt-config mysql-apt-config all 0.8.13-1 [35.6 kB]
Fetched 35.6 kB in 0s (229 kB/s)      
Preconfiguring packages ...
dpkg-deb: error: archive '/var/cache/apt/archives/mysql-apt-config_0.8.13-1_all.deb' has premature member 'control.tar.xz' before 'contro
l.tar.gz', giving up
dpkg: error processing archive /var/cache/apt/archives/mysql-apt-config_0.8.13-1_all.deb (--unpack):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /var/cache/apt/archives/mysql-apt-config_0.8.13-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

E seguito con:

$ sudo apt-get update

che non ha aiutato.

Ho ancora avuto lo stesso errore.

Infine, ha funzionato :

$ sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 5072E1F5

Sto ipotizzando (ciecamente) che forse pgp.mit.edu ha cambiato la loro struttura o forse "MySQL Release Engineering" (esegui apt-key list) ha spostato le loro chiavi sul server di chiavi Ubuntu o qualcosa del genere (non ho idea di come siano le chiavi mantenuto).

Questo commento sul thread duplicato dice la stessa cosa.

Spero che questo faccia risparmiare tempo e fatica a qualcuno.


L'ultimo passaggio ha funzionato per il mio Ubuntu 14.04 LTS, dove tutti gli altri passaggi sono falliti.
— a4aravind,

1

Semplice come dovrebbe funzionare:

apt-key adv --refresh-keys

Perché usare sede xargsse gpgpuò ordinare le cose per se stesso?


ho ricevuto il seguente errore: gpg: nessun keyserver noto (usare l'opzione --keyserver) gpg: aggiornamento del keyserver fallito: URI
— errato

0

Questa soluzione ha funzionato meglio per me.

wget -nv https://download.owncloud.org/download/repositories/stable/Ubuntu_16.04/Release.key -O Release.key

sudo apt-key add - < Release.key

Una volta eseguiti questi comandi sono stato in grado di aggiornare e aggiornare come previsto.


0

Una risposta orientata alla GUI:

Passare a /etc/apt/sources.list.d nel File Manager e fare doppio clic sources.list.

Questo dovrebbe aprire la finestra di dialogo "Software e aggiornamenti". Fai clic su "Altro software", trova il ppa offensivo, fai clic su Rimuovi. Questo ha fermato l'errore da parte mia.

Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.