Il server Ubuntu 16.04 non si avvia dopo l'installazione, Impossibile avviare LXD


9

Sono nuovo di Ubuntu. Ieri ho appena installato il server Ubuntu 16.04 sul server Dell R730. Il primo riavvio è andato bene. Ma il server ha rifiutato di avviarsi oggi. Il messaggio di errore è stato: Failed to start LXD.

messaggi di avvio

Qualcuno può aiutare, per favore?


Ho appena cercato sul web. Premi Ctrl + Alt + F1 e si è avviato correttamente. Grub rimosso e reinstallato nuovamente grub. E il problema è sparito.
— GZ,

Risposte:


7

Questo problema si verifica dopo l'aggiornamento. Il servizio LXD deve essere riavviato utilizzando l'account root.

sudo service lxd restart

È necessario riavviare in seguito, ad esempio utilizzando questo comando:

sudo reboot

1
Non è necessario inserire una shell di root usando sudo su. Basta mettere il sudodavanti a ogni singolo comando che deve essere eseguito come root. In questo modo hai i comandi registrati sotto il tuo account e hai un maggiore controllo su ciò che è in esecuzione con privilegi elevati.
— Byte Commander

1
Dopo aver eseguito "sudo service lxd restart", ci vuole molto tempo per "Avvio di LXD - demone principale ...". È normale?
— Casper,

Ho riscontrato questo problema dopo una nuova installazione di Ubuntu Server 16.04, non un aggiornamento. Anche la tua soluzione ha funzionato qui. Grazie.
— Jochem Kuijpers,
Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.