Non viene richiesto di inserire la password di root durante l'installazione di mariadb-server su Ubuntu 16.04 LTS


14

Ho appena avuto una nuova installazione sul mio PC Ubuntu 16.04 LTS. Quando ho provato a installare MariaDB digitando:

sudo apt-get install mariadb-server

L'installazione è andata senza intoppi ma durante il processo non mi è stato richiesto di inserire la password per l'account root mysql. Dopo l'installazione non sono stato in grado di accedere a MariaDB ( mysql -u root -p) e ha mostrato il messaggio di errore:

ERROR 1698 Access denied for user 'root'

Tutto era una nuova installazione. Le voci in /etc/apt/sources.listsono state verificate e tutti i componenti principali sono stati abilitati correttamente.

Quello che sembra essere il problema?


Il prompt del terminale ha un $o un #? (Chiedo perché gli utenti normali hanno $nel prompt, ma root ha #)
— Nick Weinberg

2
@NickWeinberg Penso che il problema qui sia la password di root del database non la password di root del sistema
— steeldriver

@steeldriver Ahh, ok. Ero confuso a causa del comando " sudo apt-get" e "non mi veniva chiesto di inserire la password per root". Ma penso che tu abbia ragione
— Nick Weinberg,

@DavidFoerster Stavo cercando di accedere come root in mariadb (non root in linux) da "mysql -u root -p"
— user6133116

Risposte:


17

Il pacchetto Mariadb non offre una procedura guidata di configurazione durante l'installazione su Ubuntu 16.04.

Utilizzare il comando seguente per avere una shell mysql

sudo mysql -uroot

L'ho provato e ha funzionato. Grazie. Ma ricordo prima quando ho installato mariadb mi è stato chiesto di impostare la password di root. Da quando è cambiato?
— user6133116

@ user6133116: ciò contraddice l'affermazione nella tua domanda. Qual é. Potresti chiarire, per favore?
— David Foerster,

@DavidFoerster Mi dispiace, ma non vedo alcuna contraddizione. Penso che potresti non aver avuto l'idea della mia domanda.
— user6133116

"Durante il processo [dell'installazione] non mi è stato richiesto di inserire la password per l'account root mysql" (preso dalla tua domanda, evidenziata da me) vs. "quando ho installato mariadb mi è stato chiesto di impostare la password root" ( tratto dal tuo commento)
— David Foerster,

@DavidFoerster "Ma ricordo EARLIER quando ho installato mariadb mi è stato chiesto di impostare la password di root. Da quando è stata cambiata?" Si prega di prestare attenzione alla parola "prima" che intendevo "qualche tempo fa, non questa volta". Mi è stato chiesto di impostare la password per l'account root del database prima, ma non questa volta durante questa nuova installazione, quindi la domanda pubblicata qui.
— user6133116

Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.