Impossibile avviare XAMPP su Ubuntu 11.10


14

Quando provo ad avviare XAMPP con il comando sudo / opt / lampp / lampp start mi dà un messaggio come questo.

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon with SSL is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

Cos'è questo e come posso trovare quello che era un altro demone del web server con SSL. Come fermare questo server?

Risposte:


13

Questo è un errore peculiare che otterrai se esegui XAMPP in LINUX.

Presupposto : XAMPP è decompresso @ /opt/cartella.

Se viene visualizzato l'errore "XAMPP: un altro daemon del server Web con SSL è già in esecuzione" durante l'esecuzione ./lampp start. Segui semplicemente i passaggi seguenti per eliminare questo errore:

  1. Aprire il file /opt/lampp/etc/httpd.conf.

  2. Cerca Listen 80e modificalo in un'altra porta (ad es. Listen 2145) (Riga n. 40).

  3. Aprire il file /opt/lampp/etc/extra/httpd-ssl.conf.

  4. Cerca Listen 443e modificalo in un'altra porta (ad es. Listen 16443) (Linea n. 39).

  5. Apri il file /opt/lampp/lampp

  6. Cerca la porta testport 80e sostituiscila con testport 2145. Cambia anche testport 443a testport 16443. (Sembra essere la linea n. 197, 214)

  7. Ora vai e corri /opt/lampp/lampp start. Dovrebbe funzionare ora.

Nota: i numeri di riga potrebbero essere diversi.


Tnx bro .. :) Esiste un modo per fermare quel server precedentemente in rovina?
— Asanka400,

Dipende da quale server è, se qualche processo daemon lo sta usando, le probabilità sono inferiori, prima devi sapere che quale processo sta usando la porta di default.
— somma 2000

Questo è l'errore che visualizzo se faccio clic sulla pagina phpmyadmin in xampp. Errore MySQL: Documentazione n. 2002 - Nessun file o directory simile Il server non risponde (o il socket del server locale non è configurato correttamente).
— Ram

3

Nel terminale, eseguire sudo /opt/lampp/lampp disablessl. Questo dovrebbe disabilitare ssl, dopo di che xampp si riavvierà correttamente.


Ha funzionato come un fascino. Ma c'è qualche svantaggio di disabilitare ssl in Xampp?
— Prabesh bhattarai,

2

Ho un problema simile e ho riscontrato che il problema ha causato un altro servizio già in esecuzione sulla porta 443 (SSL).

Controllare ascoltatore in esecuzione: sudo netstat -tunap | grep LISTEN. Il mio aveva vmware-hostded cupsdelencato.

Fare riferimento a http://www.apachefriends.org/en/xampp-linux.html , è necessario disattivare il servizio SSL della lampada utilizzando il comando sudo /opt/lampp/lampp stopssl, che disattiva permanentemente il supporto SSL.

Ora puoi avviare xampp: sudo /opt/lampp/lampp start


Cambiare le porte in 2145 e 16443 non ha funzionato per me. Questo è successo, e non ho bisogno di SSL .. grazie
— user568021

0

Per Ubuntu 16.04

  1. Utilizzare innanzitutto il comando nmap localhoste verificare se la porta n. 433 è in esecuzione.
  2. Se è in esecuzione, utilizzare il comando sudo kill $(sudo lsof -t -i:443)
  3. Quindi aprire il pannello di controllo xampp e avviare anche il server apache da lì.
  4. Inizierà a funzionare.
  5. Oppure puoi anche navigare verso /opt/lampp
  6. Quindi avviarlo dando il comando ./sudo xampp start

Finalmente funziona

Utilizzando il nostro sito, riconosci di aver letto e compreso le nostre Informativa sui cookie e Informativa sulla privacy.
Licensed under cc by-sa 3.0 with attribution required.